Okay, so now we have basic EIGRP, lets check our routes and make sure EIGRP is working how it should be (in regards to sucessor routes and fessiable sucessors)
BB#show ip route
172.30.0.0/24 is subnetted, 9 subnets
C 172.30.2.0 is directly connected, Loopback2
C 172.30.3.0 is directly connected, Loopback3
C 172.30.0.0 is directly connected, Loopback0
C 172.30.1.0 is directly connected, Loopback1
C 172.30.6.0 is directly connected, Loopback6
C 172.30.7.0 is directly connected, Loopback7
C 172.30.4.0 is directly connected, Loopback4
C 172.30.5.0 is directly connected, Loopback5
C 172.30.8.0 is directly connected, Loopback8
10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
D 10.1.2.0/24 [90/10537472] via 10.1.34.2, 00:05:06, Serial1/1
D 10.1.25.0/24 [90/10563072] via 10.1.34.2, 00:05:06, Serial1/1
C 10.1.24.0/30 is directly connected, Serial1/0
C 10.1.34.0/30 is directly connected, Serial1/1
S 192.168.1.0/24 is directly connected, Null0
awesome, now as we would expect we are seeing the routes in the routing
table favoring the higher bandwidth link to R3 (10.1.34.2/out
Serial1/0);
BB#show run int serial 1/1
interface Serial1/1
bandwidth 256
ip address 10.1.34.1 255.255.255.252
clock rate 2016000
end
so referring to the diagram, the quickest route to 10.1.25.0 is via R3
and over the ethernet segment, as this has twice the bandwidth of
serial1/0 link over to R2
BB#show ip route 10.1.25.0
Routing entry for 10.1.25.0/24
Known via "eigrp 90", distance 90, metric 10563072, type internal
Redistributing via eigrp 90
Last update from 10.1.34.2 on Serial1/1, 00:04:12 ago
Routing Descriptor Blocks:
* 10.1.34.2, from 10.1.34.2, 00:04:12 ago, via Serial1/1
Route metric is 10563072, traffic share count is 1
Total delay is 22000 microseconds, minimum bandwidth is 256 Kbit
Reliability 255/255, minimum MTU 1500 bytes
Loading 1/255, Hops 2
and checking against the EIGRP topology table confirms the above;
BB#show ip eigrp top 10.1.25.0 255.255.255.0
IP-EIGRP (AS 90): Topology entry for 10.1.25.0/24
State is Passive, Query origin flag is 1, 1 Successor(s), FD is 10516992
Routing Descriptor Blocks:
10.1.34.2 (Serial1/1), from 10.1.34.2, Send flag is 0x0
Composite metric is (10563072/307200), Route is Internal
Vector metric:
Minimum bandwidth is 256 Kbit
Total delay is 22000 microseconds
Reliability is 255/255
Load is 1/255
Minimum MTU is 1500
Hop count is 2
10.1.24.2 (Serial1/0), from 10.1.24.2, Send flag is 0x0
Composite metric is (20537600/281600), Route is Internal
Vector metric:
Minimum bandwidth is 128 Kbit
Total delay is 21000 microseconds
Reliability is 255/255
Load is 1/255
Minimum MTU is 1500
Hop count is 1
There we go, we see the sucessor route (this goes into the routing
table) is the route via Serial1/1 to neighbour 10.1.34.2 via the 256kbit
line, the route below it from 10.1.24.2 is the fessiable sucessor
Lets check out the topology table on the BB router;
BB#show ip eigrp top
IP-EIGRP Topology Table for AS(90)/ID(172.30.8.1)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status
P 10.1.2.0/24, 1 successors, FD is 10514432
via 10.1.34.2 (10537472/281600), Serial1/1
via 10.1.24.2 (20537600/281600), Serial1/0
P 10.1.25.0/24, 1 successors, FD is 10516992
via 10.1.34.2 (10563072/307200), Serial1/1, serno 17
via 10.1.24.2 (20537600/281600), Serial1/0
P 10.1.24.0/30, 1 successors, FD is 20512000
via Connected, Serial1/0
P 10.1.34.0/30, 1 successors, FD is 10511872
via Connected, Serial1/1
P 172.30.2.0/24, 1 successors, FD is 128256
via Connected, Loopback2
P 172.30.3.0/24, 1 successors, FD is 128256
via Connected, Loopback3
P 172.30.0.0/24, 1 successors, FD is 128256
via Connected, Loopback0
P 172.30.1.0/24, 1 successors, FD is 128256
via Connected, Loopback1
P 172.30.6.0/24, 1 successors, FD is 128256
via Connected, Loopback6
P 172.30.7.0/24, 1 successors, FD is 128256
via Connected, Loopback7
P 172.30.4.0/24, 1 successors, FD is 128256
via Connected, Loopback4
P 172.30.5.0/24, 1 successors, FD is 128256
via Connected, Loopback5
P 172.30.8.0/24, 1 successors, FD is 128256
via Connected, Loopback8
At first it may look like we have load balancing happening, but at closer inspection you see we only have x1 sucessor for the route 10.1.2.0/24 and it identifys the FD and the neighbour
P 10.1.2.0/24, 1 successors, FD is 10514432
via 10.1.34.2 (10537472/281600), Serial1/1
via 10.1.24.2 (20537600/281600), Serial1/0
10537472 = Fessiable distance, (which is determined by the K metrics)
281600 = Is Advertised Distance, this is the distance from your neighbour, so
although both of them tied on this, the fessiable distance is the
decider as to wheather they load balance or one becomes a sucessor or
not (the WAN link bandwidths in this case decided it)
SO Notice the FD of the sucessor (10537472) is roughly twice as good as the fessiable sucessor, why? ... becuase this is the bandwidth/delay .... remember the serial link bandwidths, 256kbit and 128kbit :0)
anyways, right next step, "Finally, the BB router has a static route to 192.168.1.0/24; R2 and R3 should receive this route via EIGRP without using redistribution we need a static route to be advertised about the 192.168.1.0/24"
So no redistribute static command then lol,
BB-Router(config)#ip route 192.168.1.0 255.255.255.0 null0
BB-Router#show ip route
S 192.168.1.0/24 is directly connected, Null0
Notice static routes show as "directly connected" (ignore it points to null0, thats just becuase im labbing it, it could be serial1 etc) SOooooo;
BB(config-router)#router eigrp 90
BB(config-router)#network 192.168.1.0
We can advertise it in EIGRP as if it were assigned to an interface.
lets check the neighbours and see if they have got it;
R2#show ip route | i 192.168.1.0
D 192.168.1.0/24 [90/10511872] via 10.1.34.1, 00:00:14, Serial1/0
Sweeet, right thats objective 1 done.
Just for fun, lets down the 256kbit serial link and see how long it takes for routing to recommence;
P 10.1.2.0/24, 1 successors, FD is 10514432
via 10.1.34.2 (10537472/281600), Serial1/1 <-- lets shut this 256kbit link
via 10.1.24.2 (20537600/281600), Serial1/0
R3(config)#inter serial1/0
R3(config-if)#shut
*Mar 1 00:28:05.107: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 90: Neighbor 10.1.34.1 (Serial1/0) is down: interface down
Instantly EIGRP kicks in and marks all the routes that it knew from its neighbour (BB) as unreachable (metric 4294967295)
*Mar 1 00:28:05.127: IP-EIGRP(Default-IP-Routing-Table:90): 10.1.34.0/30 - not in IP routing table
*Mar 1 00:28:05.131: IP-EIGRP(Default-IP-Routing-Table:90): Int 10.1.34.0/30 metric 4294967295 - 0 4294967295
*Mar 1 00:28:05.131: IP-EIGRP(Default-IP-Routing-Table:90): 192.168.1.0/24 - not in IP routing table
*Mar 1 00:28:05.135: IP-EIGRP(Default-IP-Routing-Table:90): Int 192.168.1.0/24 metric 4294967295 - 9999872 4294967295
*Mar 1 00:28:05.139: IP-EIGRP(Default-IP-Routing-Table:90): 172.30.2.0/24 - not in IP routing table
*Mar 1 00:28:05.139: IP-EIGRP(Default-IP-Routing-Table:90): Int 172.30.2.0/24 metric 4294967295 - 9999872 4294967295
*Mar 1 00:28:05.139: IP-EIGRP(Default-IP-Routing-Table:90): 172.30.3.0/24 - not in IP routing table
*Mar 1 00:28:05.139: IP-EIGRP(Default-IP-Routing-Table:90): Int 172.30.3.0/24 metric 4294967295 - 9999872 4294967295
*Mar 1 00:28:05.139: IP-EIGRP(Default-IP-Routing-Table:90): 172.30.0.0/24 - not in IP routing table
*Mar 1 00:28:05.139: IP-EIGRP(Default-IP-Routing-Table:90): Int 172.30.0.0/24 metric 4294967295 - 9999872 4294967295
*Mar 1 00:28:05.139: IP-EIGRP(Default-IP-Routing-Table:90): 172.30.1.0/24 - not in IP routing table
*Mar 1 00:28:05.139: IP-EIGRP(Default-IP-Routing-Table:90): Int 172.30.1.0/24 metric 4294967295 - 9999872 4294967295
*Mar 1 00:28:05.139: IP-EIGRP(Default-IP-Routing-Table:90): 172.30.6.0/24 - not in IP routing table
*Mar 1 00:28:05.139: IP-EIGRP(Default-IP-Routing-Table:90): Int 172.30.6.0/24 metric 4294967295 - 9999872 4294967295
*Mar 1 00:28:05.139: IP-EIGRP(Default-IP-Routing-Table:90): 172.30.7.0/24 - not in IP routing table
*Mar 1 00:28:05.139: IP-EIGRP(Default-IP-Routing-Table:90): Int 172.30.7.0/24 metric 4294967295 - 9999872 4294967295
*Mar 1 00:28:05.139: IP-EIGRP(Default-IP-Routing-Table:90): 172.30.4.0/24 - not in IP routing table
*Mar 1 00:28:05.139: IP-EIGRP(Default-IP-Routing-Table:90): Int 172.30.4.0/24 metric 4294967295 - 9999872 4294967295
*Mar 1 00:28:05.139: IP-EIGRP(Default-IP-Routing-Table:90): 172.30.5.0/24 - not in IP routing table
*Mar 1 00:28:05.139: IP-EIGRP(Default-IP-Routing-Table:90): Int 172.30.5.0/24 metric 4294967295 - 9999872 4294967295
*Mar 1 00:28:05.139: IP-EIGRP(Default-IP-Routing-Table:90): 172.30.8.0/24 - not in IP routing table
*Mar 1 00:28:05.139: IP-EIGRP(Default-IP-Routing-Table:90): Int 172.30.8.0/24 metric 4294967295 - 9999872 4294967295
It sends out an UPDATE packet to the BB router (with the routes above and their metrics as unreachable)
BB#
*Mar 1 00:28:02.019: IP-EIGRP(Default-IP-Routing-Table:90): Processing incoming UPDATE packet
The BB router then kicks in the Fessiable sucessor route and pops it into the table; (a total of 11 seconds)
*Mar 1 00:28:13.043: IP-EIGRP(Default-IP-Routing-Table:90): route installed for 10.1.2.0 ()
*Mar 1 00:28:13.047: IP-EIGRP(Default-IP-Routing-Table:90): route installed for 10.1.25.0 ()
Next on R3 we can a REPLY packet from the BB router, with new routes to the networks we were previously reaching via the 256kbit link;
*Mar 1 00:28:05.203: IP-EIGRP(Default-IP-Routing-Table:90): Processing incoming REPLY packet
*Mar 1 00:28:05.203: IP-EIGRP(Default-IP-Routing-Table:90): Int 10.1.34.0/30 M 21049600 - 20000000 1049600 SM 21024000 - 20000000 1024000
*Mar 1 00:28:05.207: IP-EIGRP(Default-IP-Routing-Table:90): route installed for 10.1.34.0 ()
*Mar 1 00:28:05.207: IP-EIGRP(Default-IP-Routing-Table:90): Int 192.168.1.0/24 M 20537600 - 20000000 537600 SM 20512000 - 20000000 512000
*Mar 1 00:28:05.207: IP-EIGRP(Default-IP-Routing-Table:90): route installed for 192.168.1.0 ()
*Mar 1 00:28:05.207: IP-EIGRP(Default-IP-Routing-Table:90): Int 172.30.2.0/24 M 20665600 - 20000000 665600 SM 20640000 - 20000000 640000
*Mar 1 00:28:05.207: IP-EIGRP(Default-IP-Routing-Table:90): route installed for 172.30.2.0 ()
*Mar 1 00:28:05.207: IP-EIGRP(Default-IP-Routing-Table:90): Int 172.30.3.0/24 M 20665600 - 20000000 665600 SM 20640000 - 20000000 640000
*Mar 1 00:28:05.207: IP-EIGRP(Default-IP-Routing-Table:90): route installed for 172.30.3.0 ()
*Mar 1 00:28:05.207: IP-EIGRP(Default-IP-Routing-Table:90): Int 172.30.0.0/24 M 20665600 - 20000000 665600 SM 20640000 - 20000000 640000
*Mar 1 00:28:05.207: IP-EIGRP(Default-IP-Routing-Table:90): route installed for 172.30.0.0 ()
*Mar 1 00:28:05.207: IP-EIGRP(Default-IP-Routing-Table:90): Int 172.30.1.0/24 M 20665600 - 20000000 665600 SM 20640000 - 20000000 640000
*Mar 1 00:28:05.207: IP-EIGRP(Default-IP-Routing-Table:90): route installed for 172.30.1.0 ()
*Mar 1 00:28:05.207: IP-EIGRP(Default-IP-Routing-Table:90): Int 172.30.6.0/24 M 20665600 - 20000000 665600 SM 20640000 - 20000000 640000
*Mar 1 00:28:05.207: IP-EIGRP(Default-IP-Routing-Table:90): route installed for 172.30.6.0 ()
*Mar 1 00:28:05.207: IP-EIGRP(Default-IP-Routing-Table:90): Int 172.30.7.0/24 M 20665600 - 20000000 665600 SM 20640000 - 20000000 640000
*Mar 1 00:28:05.207: IP-EIGRP(Default-IP-Routing-Table:90): route installed for 172.30.7.0 ()
*Mar 1 00:28:05.207: IP-EIGRP(Default-IP-Routing-Table:90): Int 172.30.4.0/24 M 20665600 - 20000000 665600 SM 20640000 - 20000000 640000
*Mar 1 00:28:05.207: IP-EIGRP(Default-IP-Routing-Table:90): route installed for 172.30.4.0 ()
*Mar 1 00:28:05.211: IP-EIGRP(Default-IP-Routing-Table:90): Int 172.30.5.0/24 M 20665600 - 20000000 665600 SM 20640000 - 20000000 640000
*Mar 1 00:28:05.211: IP-EIGRP(Default-IP-Routing-Table:90): route installed for 172.30.5.0 ()
*Mar 1 00:28:05.211: IP-EIGRP(Default-IP-Routing-Table:90): Int 172.30.8.0/24 M 20665600 - 20000000 665600 SM 20640000 - 20000000 640000
*Mar 1 00:28:05.211: IP-EIGRP(Default-IP-Routing-Table:90): route installed for 172.30.8.0 ()
The EIGRP Topology table on the BB router shows just the x1 link which is now a sucessor;
BB#show ip eigrp top
P 10.1.2.0/24, 1 successors, FD is 10514432
via 10.1.24.2 (20537600/281600), Serial1/0 <--- 128kbit link
Now our routing table on R3 is;
R3#show ip route
172.30.0.0/24 is subnetted, 9 subnets
D 172.30.2.0 [90/20665600] via 10.1.2.2, 00:20:28, FastEthernet0/0
D 172.30.3.0 [90/20665600] via 10.1.2.2, 00:20:28, FastEthernet0/0
D 172.30.0.0 [90/20665600] via 10.1.2.2, 00:20:28, FastEthernet0/0
D 172.30.1.0 [90/20665600] via 10.1.2.2, 00:20:28, FastEthernet0/0
D 172.30.6.0 [90/20665600] via 10.1.2.2, 00:20:28, FastEthernet0/0
D 172.30.7.0 [90/20665600] via 10.1.2.2, 00:20:28, FastEthernet0/0
D 172.30.4.0 [90/20665600] via 10.1.2.2, 00:20:29, FastEthernet0/0
D 172.30.5.0 [90/20665600] via 10.1.2.2, 00:20:29, FastEthernet0/0
D 172.30.8.0 [90/20665600] via 10.1.2.2, 00:20:29, FastEthernet0/0
10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
C 10.1.2.0/24 is directly connected, FastEthernet0/0
D 10.1.25.0/24 [90/307200] via 10.1.2.2, 00:48:13, FastEthernet0/0
D 10.1.24.0/30 [90/20537600] via 10.1.2.2, 00:48:06, FastEthernet0/0
D 192.168.1.0/24 [90/20537600] via 10.1.2.2, 00:20:31, FastEthernet0/0
If we up the link, notice the change in the routing table;
R3#show ip route
172.30.0.0/24 is subnetted, 9 subnets
D 172.30.2.0 [90/10639872] via 10.1.34.1, 00:00:33, Serial1/0
D 172.30.3.0 [90/10639872] via 10.1.34.1, 00:00:33, Serial1/0
D 172.30.0.0 [90/10639872] via 10.1.34.1, 00:00:33, Serial1/0
D 172.30.1.0 [90/10639872] via 10.1.34.1, 00:00:33, Serial1/0
D 172.30.6.0 [90/10639872] via 10.1.34.1, 00:00:33, Serial1/0
D 172.30.7.0 [90/10639872] via 10.1.34.1, 00:00:33, Serial1/0
D 172.30.4.0 [90/10639872] via 10.1.34.1, 00:00:33, Serial1/0
D 172.30.5.0 [90/10639872] via 10.1.34.1, 00:00:34, Serial1/0
D 172.30.8.0 [90/10639872] via 10.1.34.1, 00:00:34, Serial1/0
10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C 10.1.2.0/24 is directly connected, FastEthernet0/0
D 10.1.25.0/24 [90/307200] via 10.1.2.2, 00:53:26, FastEthernet0/0
D 10.1.24.0/30 [90/20537600] via 10.1.2.2, 00:00:35, FastEthernet0/0
C 10.1.34.0/30 is directly connected, Serial1/0
D 192.168.1.0/24 [90/10511872] via 10.1.34.1, 00:00:35, Serial1/0
AWESOME, totally awesome :0)
This is a blog of my journey, through my CCNP path to hopefully certification day :0)
Tuesday, 21 February 2012
Saturday, 18 February 2012
EIGRP Routing - Implementing Basic EIGRP
BB-Router(config)#router eigrp 90
BB-Router(config-router)#network 172.30.0.0 0.0.255.255
BB-Router(config-router)#network 10.1.0.0 0.0.255.255
BB-Router(config-router)#no auto-summary
BUT we can confirm that EIGRP is now running on the router;
BB-Router#show ip protocols
Routing Protocol is "eigrp 90"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Default networks flagged in outgoing updates
Default networks accepted from incoming updates
EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
EIGRP maximum hopcount 100
EIGRP maximum metric variance 1
Redistributing: eigrp 90
Automatic network summarization is not in effect
Maximum path: 4
Routing for Networks:
10.1.0.0/16 <----- shows /16 not /8 as not using default mask, tar no auto-summary
172.30.0.0 <----- This is default mask, it does not have to put /16
Routing Information Sources:
Gateway Distance Last Update
(this router) 90 00:03:51
Distance: internal 90 external 170
Lets bring the EIGRP neighbourship up, but lets enable some EIGRP debugging first *rubs hands*
R2#debug ip eigrp
R2(config)#conf t
R2(config)#router eigrp 90
R2(config-router)#no auto
R2(config-router)#network 10.1.24.2 0.0.0.0
R2(config-router)#
*Mar 1 00:17:24.203: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 90: Neighbor 10.1.24.1 (Serial1/0) is up: new adjacency
*Mar 1 00:17:24.215: IP-EIGRP(Default-IP-Routing-Table:90): Processing incoming UPDATE packet
*Mar 1 00:17:24.243: IP-EIGRP(Default-IP-Routing-Table:90): Processing incoming UPDATE packet
*Mar 1 00:17:24.247: IP-EIGRP(Default-IP-Routing-Table:90): Int 172.30.0.0/24 M 20640000 - 20000000 640000 SM 128256 - 256 128000
*Mar 1 00:17:24.247: IP-EIGRP(Default-IP-Routing-Table:90): route installed for 172.30.0.0 ()
*Mar 1 00:17:24.251: IP-EIGRP(Default-IP-Routing-Table:90): Int 172.30.1.0/24 M 20640000 - 20000000 640000 SM 128256 - 256 128000
*Mar 1 00:17:24.255: IP-EIGRP(Default-IP-Routing-Table:90): route installed for 172.30.1.0 ()
*Mar 1 00:17:24.255: IP-EIGRP(Default-IP-Routing-Table:90): Int 172.30.2.0/24 M 20640000 - 20000000 640000 SM 128256 - 256 128000
*Mar 1 00:17:24.259: IP-EIGRP(Default-IP-Routing-Table:90): route installed for 172.30.2.0 ()
*Mar 1 00:17:24.259: IP-EIGRP(Default-IP-Routing-Table:90): Int 172.30.3.0/24 M 20640000 - 20000000 640000 SM 128256 - 256 128000
*Mar 1 00:17:24.259: IP-EIGRP(Default-IP-Routing-Table:90): route installed for 172.30.3.0 ()
*Mar 1 00:17:24.259: IP-EIGRP(Default-IP-Routing-Table:90): Int 172.30.4.0/24 M 20640000 - 20000000 640000 SM 128256 - 256 128000
*Mar 1 00:17:24.259: IP-EIGRP(Default-IP-Routing-Table:90): route installed for 172.30.4.0 ()
*Mar 1 00:17:24.259: IP-EIGRP(Default-IP-Routing-Table:90): Int 172.30.5.0/24 M 20640000 - 20000000 640000 SM 128256 - 256 128000
*Mar 1 00:17:24.259: IP-EIGRP(Default-IP-Routing-Table:90): route installed for 172.30.5.0 ()
*Mar 1 00:17:24.259: IP-EIGRP(Default-IP-Routing-Table:90): Int 172.30.6.0/24 M 20640000 - 20000000 640000 SM 128256 - 256 128000
*Mar 1 00:17:24.259: IP-EIGRP(Default-IP-Routing-Table:90): route installed for 172.30.6.0 ()
*Mar 1 00:17:24.259: IP-EIGRP(Default-IP-Routing-Table:90): Int 172.30.7.0/24 M 20640000 - 20000000 640000 SM 128256 - 256 128000
*Mar 1 00:17:24.259: IP-EIGRP(Default-IP-Routing-Table:90): route installed for 172.30.7.0 ()
*Mar 1 00:17:24.259: IP-EIGRP(Default-IP-Routing-Table:90): Int 172.30.8.0/24 M 20640000 - 20000000 640000 SM 128256 - 256 128000
*Mar 1 00:17:24.259: IP-EIGRP(Default-IP-Routing-Table:90): route installed for 172.30.8.0 ()
*Mar 1 00:17:24.259: IP-EIGRP(Default-IP-Routing-Table:90): Int 10.1.34.0/30 M 21024000 - 20000000 1024000 SM 10511872 - 9999872 512000
*Mar 1 00:17:24.259: IP-EIGRP(Default-IP-Routing-Table:90): route installed for 10.1.34.0 ()
*Mar 1 00:17:24.259: IP-EIGRP(Default-IP-Routing-Table:90): 10.1.24.0/30 - do advertise out Serial1/0
*Mar 1 00:17:24.311: IP-EIGRP(Default-IP-Routing-Table:90): Processing incoming UPDATE packet
*Mar 1 00:17:24.315: IP-EIGRP(Default-IP-Routing-Table:90): Int 172.30.0.0/24 M 20640000 - 20000000 640000 SM 128256 - 256 128000
*Mar 1 00:17:24.319: IP-EIGRP(Default-IP-Routing-Table:90): Int 172.30.1.0/24 M 20640000 - 20000000 640000 SM 128256 - 256 128000
*Mar 1 00:17:24.319: IP-EIGRP(Default-IP-Routing-Table:90): Int 172.30.2.0/24 M 20640000 - 20000000 640000 SM 128256 - 256 128000
*Mar 1 00:17:24.323: IP-EIGRP(Default-IP-Routing-Table:90): Int 172.30.3.0/24 M 20640000 - 20000000 640000 SM 128256 - 256 128000
*Mar 1 00:17:24.323: IP-EIGRP(Default-IP-Routing-Table:90): Int 172.30.4.0/24 M 20640000 - 20000000 640000 SM 128256 - 256 128000
*Mar 1 00:17:24.323: IP-EIGRP(Default-IP-Routing-Table:90): Int 172.30.5.0/24 M 20640000 - 20000000 640000 SM 128256 - 256 128000
*Mar 1 00:17:24.323: IP-EIGRP(Default-IP-Routing-Table:90): Int 172.30.6.0/24 M 20640000 - 20000000 640000 SM 128256 - 256 128000
*Mar 1 00:17:24.323: IP-EIGRP(Default-IP-Routing-Table:90): Int 172.30.7.0/24 M 20640000 - 20000000 640000 SM 128256 - 256 128000
*Mar 1 00:17:24.323: IP-EIGRP(Default-IP-Routing-Table:90): Int 172.30.8.0/24 M 20640000 - 20000000 640000 SM 128256 - 256 128000
*Mar 1 00:17:24.323: IP-EIGRP(Default-IP-Routing-Table:90): Int 10.1.34.0/30 M 21024000 - 20000000 1024000 SM 10511872 - 9999872 512000
*Mar 1 00:17:24.323: IP-EIGRP(Default-IP-Routing-Table:90): 10.1.24.0/30 - do advertise out Serial1/0
R2(config-router)#
So above we can see all internal routes being learnt from our neighbour, showing their source metric (bandwith and delay) and Admin Distance
R2(config)#router eigrp 90
R2(config-router)#network 10.1.2.2 0.0.0.0
R2(config-router)#
*Mar 1 01:07:33.599: IP-EIGRP(Default-IP-Routing-Table:90): 10.1.2.0/24 - do advertise out Serial1/0
*Mar 1 01:07:33.599: IP-EIGRP(Default-IP-Routing-Table:90): Int 10.1.2.0/24 metric 281600 - 256000 25600
R2(config-router)#network 10.1.25.2 0.0.0.0
R2(config-router)#
*Mar 1 01:07:44.651: IP-EIGRP(Default-IP-Routing-Table:90): 10.1.25.0/24 - do advertise out Serial1/0
*Mar 1 01:07:44.655: IP-EIGRP(Default-IP-Routing-Table:90): Int 10.1.25.0/24 metric 281600 - 256000 25600
R2#show ip route
172.30.0.0/24 is subnetted, 9 subnets
D 172.30.2.0 [90/20640000] via 10.1.24.1, 00:50:34, Serial1/0
D 172.30.3.0 [90/20640000] via 10.1.24.1, 00:50:34, Serial1/0
D 172.30.0.0 [90/20640000] via 10.1.24.1, 00:50:34, Serial1/0
D 172.30.1.0 [90/20640000] via 10.1.24.1, 00:50:34, Serial1/0
D 172.30.6.0 [90/20640000] via 10.1.24.1, 00:50:34, Serial1/0
D 172.30.7.0 [90/20640000] via 10.1.24.1, 00:50:34, Serial1/0
D 172.30.4.0 [90/20640000] via 10.1.24.1, 00:50:34, Serial1/0
D 172.30.5.0 [90/20640000] via 10.1.24.1, 00:50:35, Serial1/0
D 172.30.8.0 [90/20640000] via 10.1.24.1, 00:50:35, Serial1/0
10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C 10.1.2.0/24 is directly connected, FastEthernet0/0
C 10.1.25.0/24 is directly connected, FastEthernet0/1
C 10.1.24.0/30 is directly connected, Serial1/0
D 10.1.34.0/30 [90/21024000] via 10.1.24.1, 00:50:37, Serial1/0
R2#show ip eigrp ne
IP-EIGRP neighbors for process 90
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 10.1.24.1 Se1/0 13 00:51:00 20 1140 0 6
R2#
awesome! lets jump over to R3;
R3(config)#router eigrp 90
R3(config-router)#no auto-summary
R3(config-router)#network 10.1.2.3 0.0.0.0
R3(config-router)#network 10.1.34.2 0.0.0.0
We now have the basic EIGRP lab setup (however i spent alot more time than i thought looking into the debugs lol) will continue with the rest of this lab tomorrow peeps
BB-Router(config)#router eigrp 90
BB-Router(config-router)#network 172.30.0.0 0.0.255.255
BB-Router(config-router)#network 10.1.0.0 0.0.255.255
BB-Router(config-router)#no auto-summary
BUT we can confirm that EIGRP is now running on the router;
BB-Router#show ip protocols
Routing Protocol is "eigrp 90"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Default networks flagged in outgoing updates
Default networks accepted from incoming updates
EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
EIGRP maximum hopcount 100
EIGRP maximum metric variance 1
Redistributing: eigrp 90
Automatic network summarization is not in effect
Maximum path: 4
Routing for Networks:
10.1.0.0/16 <----- shows /16 not /8 as not using default mask, tar no auto-summary
172.30.0.0 <----- This is default mask, it does not have to put /16
Routing Information Sources:
Gateway Distance Last Update
(this router) 90 00:03:51
Distance: internal 90 external 170
Lets bring the EIGRP neighbourship up, but lets enable some EIGRP debugging first *rubs hands*
R2#debug ip eigrp
R2(config)#conf t
R2(config)#router eigrp 90
R2(config-router)#no auto
R2(config-router)#network 10.1.24.2 0.0.0.0
R2(config-router)#
*Mar 1 00:17:24.203: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 90: Neighbor 10.1.24.1 (Serial1/0) is up: new adjacency
*Mar 1 00:17:24.215: IP-EIGRP(Default-IP-Routing-Table:90): Processing incoming UPDATE packet
*Mar 1 00:17:24.243: IP-EIGRP(Default-IP-Routing-Table:90): Processing incoming UPDATE packet
*Mar 1 00:17:24.247: IP-EIGRP(Default-IP-Routing-Table:90): Int 172.30.0.0/24 M 20640000 - 20000000 640000 SM 128256 - 256 128000
*Mar 1 00:17:24.247: IP-EIGRP(Default-IP-Routing-Table:90): route installed for 172.30.0.0 ()
*Mar 1 00:17:24.251: IP-EIGRP(Default-IP-Routing-Table:90): Int 172.30.1.0/24 M 20640000 - 20000000 640000 SM 128256 - 256 128000
*Mar 1 00:17:24.255: IP-EIGRP(Default-IP-Routing-Table:90): route installed for 172.30.1.0 ()
*Mar 1 00:17:24.255: IP-EIGRP(Default-IP-Routing-Table:90): Int 172.30.2.0/24 M 20640000 - 20000000 640000 SM 128256 - 256 128000
*Mar 1 00:17:24.259: IP-EIGRP(Default-IP-Routing-Table:90): route installed for 172.30.2.0 ()
*Mar 1 00:17:24.259: IP-EIGRP(Default-IP-Routing-Table:90): Int 172.30.3.0/24 M 20640000 - 20000000 640000 SM 128256 - 256 128000
*Mar 1 00:17:24.259: IP-EIGRP(Default-IP-Routing-Table:90): route installed for 172.30.3.0 ()
*Mar 1 00:17:24.259: IP-EIGRP(Default-IP-Routing-Table:90): Int 172.30.4.0/24 M 20640000 - 20000000 640000 SM 128256 - 256 128000
*Mar 1 00:17:24.259: IP-EIGRP(Default-IP-Routing-Table:90): route installed for 172.30.4.0 ()
*Mar 1 00:17:24.259: IP-EIGRP(Default-IP-Routing-Table:90): Int 172.30.5.0/24 M 20640000 - 20000000 640000 SM 128256 - 256 128000
*Mar 1 00:17:24.259: IP-EIGRP(Default-IP-Routing-Table:90): route installed for 172.30.5.0 ()
*Mar 1 00:17:24.259: IP-EIGRP(Default-IP-Routing-Table:90): Int 172.30.6.0/24 M 20640000 - 20000000 640000 SM 128256 - 256 128000
*Mar 1 00:17:24.259: IP-EIGRP(Default-IP-Routing-Table:90): route installed for 172.30.6.0 ()
*Mar 1 00:17:24.259: IP-EIGRP(Default-IP-Routing-Table:90): Int 172.30.7.0/24 M 20640000 - 20000000 640000 SM 128256 - 256 128000
*Mar 1 00:17:24.259: IP-EIGRP(Default-IP-Routing-Table:90): route installed for 172.30.7.0 ()
*Mar 1 00:17:24.259: IP-EIGRP(Default-IP-Routing-Table:90): Int 172.30.8.0/24 M 20640000 - 20000000 640000 SM 128256 - 256 128000
*Mar 1 00:17:24.259: IP-EIGRP(Default-IP-Routing-Table:90): route installed for 172.30.8.0 ()
*Mar 1 00:17:24.259: IP-EIGRP(Default-IP-Routing-Table:90): Int 10.1.34.0/30 M 21024000 - 20000000 1024000 SM 10511872 - 9999872 512000
*Mar 1 00:17:24.259: IP-EIGRP(Default-IP-Routing-Table:90): route installed for 10.1.34.0 ()
*Mar 1 00:17:24.259: IP-EIGRP(Default-IP-Routing-Table:90): 10.1.24.0/30 - do advertise out Serial1/0
*Mar 1 00:17:24.311: IP-EIGRP(Default-IP-Routing-Table:90): Processing incoming UPDATE packet
*Mar 1 00:17:24.315: IP-EIGRP(Default-IP-Routing-Table:90): Int 172.30.0.0/24 M 20640000 - 20000000 640000 SM 128256 - 256 128000
*Mar 1 00:17:24.319: IP-EIGRP(Default-IP-Routing-Table:90): Int 172.30.1.0/24 M 20640000 - 20000000 640000 SM 128256 - 256 128000
*Mar 1 00:17:24.319: IP-EIGRP(Default-IP-Routing-Table:90): Int 172.30.2.0/24 M 20640000 - 20000000 640000 SM 128256 - 256 128000
*Mar 1 00:17:24.323: IP-EIGRP(Default-IP-Routing-Table:90): Int 172.30.3.0/24 M 20640000 - 20000000 640000 SM 128256 - 256 128000
*Mar 1 00:17:24.323: IP-EIGRP(Default-IP-Routing-Table:90): Int 172.30.4.0/24 M 20640000 - 20000000 640000 SM 128256 - 256 128000
*Mar 1 00:17:24.323: IP-EIGRP(Default-IP-Routing-Table:90): Int 172.30.5.0/24 M 20640000 - 20000000 640000 SM 128256 - 256 128000
*Mar 1 00:17:24.323: IP-EIGRP(Default-IP-Routing-Table:90): Int 172.30.6.0/24 M 20640000 - 20000000 640000 SM 128256 - 256 128000
*Mar 1 00:17:24.323: IP-EIGRP(Default-IP-Routing-Table:90): Int 172.30.7.0/24 M 20640000 - 20000000 640000 SM 128256 - 256 128000
*Mar 1 00:17:24.323: IP-EIGRP(Default-IP-Routing-Table:90): Int 172.30.8.0/24 M 20640000 - 20000000 640000 SM 128256 - 256 128000
*Mar 1 00:17:24.323: IP-EIGRP(Default-IP-Routing-Table:90): Int 10.1.34.0/30 M 21024000 - 20000000 1024000 SM 10511872 - 9999872 512000
*Mar 1 00:17:24.323: IP-EIGRP(Default-IP-Routing-Table:90): 10.1.24.0/30 - do advertise out Serial1/0
R2(config-router)#
So above we can see all internal routes being learnt from our neighbour, showing their source metric (bandwith and delay) and Admin Distance
R2(config)#router eigrp 90
R2(config-router)#network 10.1.2.2 0.0.0.0
R2(config-router)#
*Mar 1 01:07:33.599: IP-EIGRP(Default-IP-Routing-Table:90): 10.1.2.0/24 - do advertise out Serial1/0
*Mar 1 01:07:33.599: IP-EIGRP(Default-IP-Routing-Table:90): Int 10.1.2.0/24 metric 281600 - 256000 25600
R2(config-router)#network 10.1.25.2 0.0.0.0
R2(config-router)#
*Mar 1 01:07:44.651: IP-EIGRP(Default-IP-Routing-Table:90): 10.1.25.0/24 - do advertise out Serial1/0
*Mar 1 01:07:44.655: IP-EIGRP(Default-IP-Routing-Table:90): Int 10.1.25.0/24 metric 281600 - 256000 25600
R2#show ip route
172.30.0.0/24 is subnetted, 9 subnets
D 172.30.2.0 [90/20640000] via 10.1.24.1, 00:50:34, Serial1/0
D 172.30.3.0 [90/20640000] via 10.1.24.1, 00:50:34, Serial1/0
D 172.30.0.0 [90/20640000] via 10.1.24.1, 00:50:34, Serial1/0
D 172.30.1.0 [90/20640000] via 10.1.24.1, 00:50:34, Serial1/0
D 172.30.6.0 [90/20640000] via 10.1.24.1, 00:50:34, Serial1/0
D 172.30.7.0 [90/20640000] via 10.1.24.1, 00:50:34, Serial1/0
D 172.30.4.0 [90/20640000] via 10.1.24.1, 00:50:34, Serial1/0
D 172.30.5.0 [90/20640000] via 10.1.24.1, 00:50:35, Serial1/0
D 172.30.8.0 [90/20640000] via 10.1.24.1, 00:50:35, Serial1/0
10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C 10.1.2.0/24 is directly connected, FastEthernet0/0
C 10.1.25.0/24 is directly connected, FastEthernet0/1
C 10.1.24.0/30 is directly connected, Serial1/0
D 10.1.34.0/30 [90/21024000] via 10.1.24.1, 00:50:37, Serial1/0
R2#show ip eigrp ne
IP-EIGRP neighbors for process 90
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 10.1.24.1 Se1/0 13 00:51:00 20 1140 0 6
R2#
awesome! lets jump over to R3;
R3(config)#router eigrp 90
R3(config-router)#no auto-summary
R3(config-router)#network 10.1.2.3 0.0.0.0
R3(config-router)#network 10.1.34.2 0.0.0.0
We now have the basic EIGRP lab setup (however i spent alot more time than i thought looking into the debugs lol) will continue with the rest of this lab tomorrow peeps
Subscribe to:
Posts (Atom)